Skip to main content
← All vulnerabilities
CVE-2014-3526GHSA-Q7WX-MHX4-JR8Q

Apache Wicket before 1.5.12, 6.x before 6.17.0, and 7.x before 7.0.0-M3 might allow remote attackers to obtain sensitive information via vec

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.5.12, 6.17.0, 7.0.0-M3
None on Exploit-DB, Metasploit or GitHub

Summary

Apache Wicket before 1.5.12, 6.x before 6.17.0, and 7.x before 7.0.0-M3 might allow remote attackers to obtain sensitive information via vectors involving identifiers for storing page markup for temporary user sessions.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • org.apache.wicket:wicket-coreMaven

    fixed in 1.5.12

  • org.apache.wicket:wicket-coreMaven

    From 6.0 · fixed in 6.17.0

  • org.apache.wicket:wicket-coreMaven

    From 7.0.0-M1 · fixed in 7.0.0-M3

References 1

wicket.apache.org