Zend Framework 1 (ZF1) before 1.12.4, Zend Framework 2 before 2.1.6 and 2.2.x before 2.2.6, ZendOpenId, ZendRest, ZendService_AudioScrobbler
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.12.4, 2.0.2, 2.0.3, 1.0.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Zend Framework 1 (ZF1) before 1.12.4, Zend Framework 2 before 2.1.6 and 2.2.x before 2.2.6, ZendOpenId, ZendRest, ZendService_AudioScrobbler, ZendService_Nirvanix, ZendService_SlideShare, ZendService_Technorati, and ZendService_WindowsAzure before 2.0.2, ZendService_Amazon before 2.0.3, and ZendService_Api before 1.0.0 allow remote attackers to read arbitrary files, send HTTP requests to intranet servers, and possibly cause a denial of service (CPU and memory consumption) via an XML External Entity (XXE) attack. NOTE: this issue exists because of an incomplete fix for CVE-2012-5657.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- zendframework/zendframework1Packagist
fixed in 1.12.4
- zendframework/zendopenidPackagist
fixed in 2.0.2
- zendframework/zendrestPackagist
fixed in 2.0.2
- zendframework/zendservice-audioscrobblerPackagist
fixed in 2.0.2
- zendframework/zendservice-nirvanixPackagist
fixed in 2.0.2
- zendframework/zendservice-slidesharePackagist
fixed in 2.0.2
- zendframework/zendservice-technoratiPackagist
fixed in 2.0.2
- zendframework/zendservice-windowsazurePackagist
fixed in 2.0.2
- zendframework/zendservice-amazonPackagist
fixed in 2.0.3
- zendframework/zendservice-apiPackagist
fixed in 1.0.0