Skip to main content
← All vulnerabilities
CVE-2014-2571GHSA-75C6-XQWR-V2R9

Cross-site scripting (XSS) vulnerability in the quiz_question_tostring function in mod/quiz/editlib.php in Moodle through 2.3.11, 2.4.x befo

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.9, 2.5.5, 2.6.2
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in the quiz_question_tostring function in mod/quiz/editlib.php in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 allows remote authenticated users to inject arbitrary web script or HTML via a quiz question.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.4.9

  • moodle/moodlePackagist

    From 2.5.0 · fixed in 2.5.5

  • moodle/moodlePackagist

    From 2.6.0 · fixed in 2.6.2

References 3

git.moodle.org

openwall.com

moodle.org