Skip to main content
← All vulnerabilities
CVE-2014-1868GHSA-73CQ-FHP3-8RPW

Restlet Framework 2.1.x before 2.1.7 and 2.x.x before 2.2 RC1, when using XMLRepresentation or XML serializers, allows attackers to cause a

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.1.7
None on Exploit-DB, Metasploit or GitHub

Summary

Restlet Framework 2.1.x before 2.1.7 and 2.x.x before 2.2 RC1, when using XMLRepresentation or XML serializers, allows attackers to cause a denial of service via an XML Entity Expansion (XEE) attack.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • org.restlet.jse:org.restletMaven

    From 2.1.0 · fixed in 2.1.7

References 3

secunia.com

GitHub · restlet/restlet-framework-java

exchange.xforce.ibmcloud.com