CVE-2014-0482GHSA-625G-GX8C-XCMGPYSEC-2014-6
The contrib.auth.middleware.RemoteUserMiddleware middleware in Django before 1.4.14, 1.5.x before 1.5.9, 1.6.x before 1.6.6, and 1.7 before
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.4.14, 1.5.9, 1.6.6, 1.7c3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The contrib.auth.middleware.RemoteUserMiddleware middleware in Django before 1.4.14, 1.5.x before 1.5.9, 1.6.x before 1.6.6, and 1.7 before release candidate 3, when using the contrib.auth.backends.RemoteUserBackend backend, allows remote authenticated users to hijack web sessions via vectors related to the REMOTE_USER header.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- djangoPyPI
fixed in 1.4.14
- djangoPyPI
From 1.5 · fixed in 1.5.9
- djangoPyPI
From 1.6 · fixed in 1.6.6
- djangoPyPI
From 1.7a1 · fixed in 1.7c3
- djangoPyPI
fixed in 1.4.14; From 1.5 · fixed in 1.5.9; From 1.6 · fixed in 1.6.6