Skip to main content
← All vulnerabilities
CVE-2014-0229GHSA-9R7G-325H-MXRM

Apache Hadoop 0.23.x before 0.23.11 and 2.x before 2.4.1, as used in Cloudera CDH 5.0.x before 5.0.2, do not check authorization for the (1)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.23.11, 2.4.1
None on Exploit-DB, Metasploit or GitHub

Summary

Apache Hadoop 0.23.x before 0.23.11 and 2.x before 2.4.1, as used in Cloudera CDH 5.0.x before 5.0.2, do not check authorization for the (1) refreshNamenodes, (2) deleteBlockPool, and (3) shutdownDatanode HDFS admin commands, which allows remote authenticated users to cause a denial of service (DataNodes shutdown) or perform unnecessary operations by issuing a command.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • org.apache.hadoop:hadoop-commonMaven

    From 0.23.0 · fixed in 0.23.11

  • org.apache.hadoop:hadoop-commonMaven

    From 2.0.0 · fixed in 2.4.1

References 1

cloudera.com