Skip to main content
← All vulnerabilities
CVE-2014-0217GHSA-C3VX-V4X8-X894

enrol/index.php in Moodle 2.6.x before 2.6.3 does not check for the moodle/course:viewhiddencourses capability before listing hidden courses

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.6.3
None on Exploit-DB, Metasploit or GitHub

Summary

enrol/index.php in Moodle 2.6.x before 2.6.3 does not check for the moodle/course:viewhiddencourses capability before listing hidden courses, which allows remote attackers to obtain sensitive name and summary information about these courses by leveraging the guest role and visiting a crafted URL.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    From 2.6.0 · fixed in 2.6.3

References 3

moodle.org

openwall.com

git.moodle.org