Skip to main content
← All vulnerabilities
CVE-2014-0215GHSA-2FMV-J5XJ-4FMQ

The blind-marking implementation in Moodle through 2.3.11, 2.4.x before 2.4.10, 2.5.x before 2.5.6, and 2.6.x before 2.6.3 allows remote aut

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.0, 2.5.6, 2.4.10
None on Exploit-DB, Metasploit or GitHub

Summary

The blind-marking implementation in Moodle through 2.3.11, 2.4.x before 2.4.10, 2.5.x before 2.5.6, and 2.6.x before 2.6.3 allows remote authenticated users to de-anonymize student identities by (1) using a screen reader or (2) reading the HTML source.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    From 2.6.0 · fixed in 2.7.0

  • moodle/moodlePackagist

    From 2.5.0 · fixed in 2.5.6

  • moodle/moodlePackagist

    From 2.4.0 · fixed in 2.4.10

References 3

git.moodle.org

moodle.org

openwall.com