Skip to main content
← All vulnerabilities
CVE-2014-0124GHSA-FC5P-VJ3H-X7G4

The identity-reporting implementations in mod/forum/renderer.php and mod/quiz/override_form.php in Moodle through 2.3.11, 2.4.x before 2.4.9

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.9, 2.5.5, 2.6.2
None on Exploit-DB, Metasploit or GitHub

Summary

The identity-reporting implementations in mod/forum/renderer.php and mod/quiz/override_form.php in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 do not properly restrict the display of e-mail addresses, which allows remote authenticated users to obtain sensitive information by using the (1) Forum or (2) Quiz module.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.4.9

  • moodle/moodlePackagist

    From 2.5.0 · fixed in 2.5.5

  • moodle/moodlePackagist

    From 2.6.0 · fixed in 2.6.2

References 3

git.moodle.org

openwall.com

moodle.org