Skip to main content
← All vulnerabilities
CVE-2014-0123GHSA-2VHR-4MHQ-M35C

The wiki subsystem in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 does not properly restrict (1) v

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.9, 2.5.5, 2.6.2
None on Exploit-DB, Metasploit or GitHub

Summary

The wiki subsystem in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 does not properly restrict (1) view and (2) edit access, which allows remote authenticated users to perform wiki operations by leveraging the student role and using the Recent Activity block to reach the individual wiki of an arbitrary student.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.4.9

  • moodle/moodlePackagist

    From 2.5.0 · fixed in 2.5.5

  • moodle/moodlePackagist

    From 2.6.0 · fixed in 2.6.2

References 3

openwall.com

moodle.org

git.moodle.org