Skip to main content
← All vulnerabilities
CVE-2014-0111GHSA-R2XF-W5PJ-9PW8

Apache Syncope 1.0.0 before 1.0.9 and 1.1.0 before 1.1.7 allows remote administrators to execute arbitrary Java code via vectors related to

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.0.9, 1.1.7
None on Exploit-DB, Metasploit or GitHub

Summary

Apache Syncope 1.0.0 before 1.0.9 and 1.1.0 before 1.1.7 allows remote administrators to execute arbitrary Java code via vectors related to Apache Commons JEXL expressions, "derived schema definition," "user / role templates," and "account links of resource mappings."

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • org.apache.syncope:syncopeMaven

    From 1.0.0 · fixed in 1.0.9

  • org.apache.syncope:syncopeMaven

    From 1.1.0 · fixed in 1.1.7

References 3

mail-archives.us.apache.org

syncope.apache.org

securityfocus.com