CVE-2014-0046GHSA-4Q53-FQHC-CR46
Cross-site scripting (XSS) vulnerability in the link-to helper in Ember.js 1.2.x before 1.2.2, 1.3.x before 1.3.2, and 1.4.x before 1.4.0-be
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.2.2, 1.3.2, 1.4.0.beta.6
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Cross-site scripting (XSS) vulnerability in the link-to helper in Ember.js 1.2.x before 1.2.2, 1.3.x before 1.3.2, and 1.4.x before 1.4.0-beta.6, when used in non-block form, allows remote attackers to inject arbitrary web script or HTML via the title attribute.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- ember-sourceRubyGems
From 1.2.0 · fixed in 1.2.2
- ember-sourceRubyGems
From 1.3.0 · fixed in 1.3.2
- ember-sourceRubyGems
From 1.4.0.beta.1 · fixed in 1.4.0.beta.6