Skip to main content
← All vulnerabilities
CVE-2014-0014GHSA-RCX6-7JP6-PQF2

Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1, and 1.4.x before 1.4.0-beta.2 allows remote attacke

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.0.1, 1.1.3, 1.2.1, 1.3.1, 1.4.0-beta.2
None on Exploit-DB, Metasploit or GitHub

Summary

Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1, and 1.4.x before 1.4.0-beta.2 allows remote attackers to conduct cross-site scripting (XSS) attacks by leveraging an application using the "{{group}}" Helper and a crafted payload.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • ember-sourceRubyGems

    From 1.0.0.pre4.0 · fixed in 1.0.1

  • ember-sourceRubyGems

    From 1.1.0 · fixed in 1.1.3

  • ember-sourceRubyGems

    From 1.2.0.beta.1 · fixed in 1.2.1

  • ember-sourceRubyGems

    From 1.3.0.beta.1 · fixed in 1.3.1

  • ember-sourceRubyGems

    From 1.4.0-beta.1 · fixed in 1.4.0-beta.2

References 3

groups.google.com

emberjs.com

oracle.com