CVE-2014-0013GHSA-8XM3-GM7C-5FJX
Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1, and 1.4.x before 1.4.0-beta.2 allows remote attacke
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.0.1, 1.1.3, 1.2.1, 1.3.1, 1.4.0-beta.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1, and 1.4.x before 1.4.0-beta.2 allows remote attackers to conduct cross-site scripting (XSS) attacks by leveraging an application that contains templates whose context is set to a user-supplied primitive value and also contain the `{{this}}` special Handlebars variable.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- ember-sourceRubyGems
From 1.0.0.pre4.0 · fixed in 1.0.1
- ember-sourceRubyGems
From 1.1.0 · fixed in 1.1.3
- ember-sourceRubyGems
From 1.2.0.beta.1 · fixed in 1.2.1
- ember-sourceRubyGems
From 1.3.0.beta.1 · fixed in 1.3.1
- ember-sourceRubyGems
From 1.4.0-beta.1 · fixed in 1.4.0-beta.2