Skip to main content
← All vulnerabilities
CVE-2013-7285GHSA-F554-X222-WGF7

Xstream API versions up to 1.4.6 and version 1.4.10, if the security framework has not been initialized, may allow a remote attacker to run

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.4.7, 1.4.11
1 on Exploit-DB
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Xstream API versions up to 1.4.6 and version 1.4.10, if the security framework has not been initialized, may allow a remote attacker to run arbitrary shell commands by manipulating the processed input stream when unmarshaling XML or any supported format. e.g. JSON.

Timeline

  1. Public exploit on Exploit-DB

    EDB-39193

  2. CVE published
  3. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • com.thoughtworks.xstream:xstreamMaven

    fixed in 1.4.7

  • com.thoughtworks.xstream:xstreamMaven

    From 1.4.10 · fixed in 1.4.11

References 10

seclists.org

mail-archive.com

lists.apache.org

blog.diniscruz.com

x-stream.github.io

oracle.com

web.archive.org

Exploit-DB