Skip to main content
← All vulnerabilities
CVE-2013-6415GHSA-6H5Q-96HP-9JGM

Cross-site scripting (XSS) vulnerability in the number_to_currency helper in actionpack/lib/action_view/helpers/number_helper.rb in Ruby on

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.2.16, 4.0.2
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in the number_to_currency helper in actionpack/lib/action_view/helpers/number_helper.rb in Ruby on Rails before 3.2.16 and 4.x before 4.0.2 allows remote attackers to inject arbitrary web script or HTML via the unit parameter.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • actionpackRubyGems

    From 3.0.0 · fixed in 3.2.16

  • actionpackRubyGems

    From 4.0.0 · fixed in 4.0.2

References 15

rhn.redhat.com

lists.opensuse.org

puppet.com

groups.google.com

weblog.rubyonrails.org

securityfocus.com

secunia.com

debian.org