Skip to main content
← All vulnerabilities
CVE-2013-5958GHSA-CR49-FX2V-9P57

The Security component in Symfony 2.0.x before 2.0.25, 2.1.x before 2.1.13, 2.2.x before 2.2.9, and 2.3.x before 2.3.6 allows remote attacke

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.0.25, 2.1.13, 2.2.9, 2.3.6, 1.10.0
None on Exploit-DB, Metasploit or GitHub

Summary

The Security component in Symfony 2.0.x before 2.0.25, 2.1.x before 2.1.13, 2.2.x before 2.2.9, and 2.3.x before 2.3.6 allows remote attackers to cause a denial of service (CPU consumption) via a long password that triggers an expensive hash computation, as demonstrated by a PBKDF2 computation, a similar issue to CVE-2013-5750.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • symfony/symfonyPackagist

    From 2.0.0 · fixed in 2.0.25

  • symfony/symfonyPackagist

    From 2.1.0 · fixed in 2.1.13

  • symfony/symfonyPackagist

    From 2.2.0 · fixed in 2.2.9

  • symfony/symfonyPackagist

    From 2.3.0 · fixed in 2.3.6

  • symfony/polyfillPackagist

    From 1.0.0 · fixed in 1.10.0

  • symfony/securityPackagist

    From 2.0.0 · fixed in 2.0.25

  • symfony/securityPackagist

    From 2.1.0 · fixed in 2.1.13

  • symfony/securityPackagist

    From 2.2.0 · fixed in 2.2.9

  • symfony/securityPackagist

    From 2.3.0 · fixed in 2.3.6

References 1

symfony.com