Skip to main content
← All vulnerabilities
CVE-2013-4942GHSA-9WW8-J8J2-3788

Cross-site scripting (XSS) vulnerability in flashuploader.swf in the Uploader component in Yahoo! YUI 3.5.0 through 3.9.1, as used in Moodle

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.11, 2.3.8, 2.4.5, 2.5.1
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in flashuploader.swf in the Uploader component in Yahoo! YUI 3.5.0 through 3.9.1, as used in Moodle through 2.1.10, 2.2.x before 2.2.11, 2.3.x before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.1, and other products, allows remote attackers to inject arbitrary web script or HTML via a crafted string in a URL.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • yuinpm

    From 3.2.0 · through 3.9.1

  • moodle/moodlePackagist

    fixed in 2.2.11

  • moodle/moodlePackagist

    From 2.3.0 · fixed in 2.3.8

  • moodle/moodlePackagist

    From 2.4.0-rc1 · fixed in 2.4.5

  • moodle/moodlePackagist

    From 2.5.0-beta · fixed in 2.5.1

References 3

moodle.org

git.moodle.org

yuilibrary.com