Skip to main content
← All vulnerabilities
CVE-2013-4940GHSA-X5HJ-47VV-53P8

Cross-site scripting (XSS) vulnerability in io.swf in the IO Utility component in Yahoo! YUI 3.10.2, as used in Moodle through 2.1.10, 2.2.x

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.10.11, 3.10.13, 2.2.11, 2.3.8, 2.4.5, and 1 more
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in io.swf in the IO Utility component in Yahoo! YUI 3.10.2, as used in Moodle through 2.1.10, 2.2.x before 2.2.11, 2.3.x before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.1, and other products, allows remote attackers to inject arbitrary web script or HTML via a crafted string in a URL. NOTE: this vulnerability exists because of a CVE-2013-4939 regression.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • yuinpm

    From 3.0.0 · fixed in 3.10.11

  • yuinpm

    From 3.10.12 · fixed in 3.10.13

  • moodle/moodlePackagist

    fixed in 2.2.11

  • moodle/moodlePackagist

    From 2.3.0 · fixed in 2.3.8

  • moodle/moodlePackagist

    From 2.4.0-rc1 · fixed in 2.4.5

  • moodle/moodlePackagist

    From 2.5.0-beta · fixed in 2.5.1

References 3

moodle.org

git.moodle.org

yuilibrary.com