Skip to main content
← All vulnerabilities
CVE-2013-4761GHSA-CJ43-9H3W-V976

Unspecified vulnerability in Puppet 2.7.x before 2.7.23 and 3.2.x before 3.2.4, and Puppet Enterprise 2.8.x before 2.8.3 and 3.0.x before 3.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.23, 3.2.4
None on Exploit-DB, Metasploit or GitHub

Summary

Unspecified vulnerability in Puppet 2.7.x before 2.7.23 and 3.2.x before 3.2.4, and Puppet Enterprise 2.8.x before 2.8.3 and 3.0.x before 3.0.1, allows remote attackers to execute arbitrary Ruby programs from the master via the resource_type service. NOTE: this vulnerability can only be exploited utilizing unspecified "local file system access" to the Puppet Master.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • puppetRubyGems

    From 2.7.0 · fixed in 2.7.23

  • puppetRubyGems

    From 3.2.0 · fixed in 3.2.4

References 5

debian.org

lists.opensuse.org

puppetlabs.com

rhn.redhat.com