Skip to main content
← All vulnerabilities
CVE-2013-4662GHSA-4465-R2HG-V4RJ

The Quick Search API in CiviCRM 4.2.0 through 4.2.9 and 4.3.0 through 4.3.3 allows remote authenticated users to bypass the validation layer

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.2.9, 4.3.3
None on Exploit-DB, Metasploit or GitHub

Summary

The Quick Search API in CiviCRM 4.2.0 through 4.2.9 and 4.3.0 through 4.3.3 allows remote authenticated users to bypass the validation layer and conduct SQL injection attacks via a direct request to the "second layer" of the API, related to contact.getquick.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • civicrm/civicrm-corePackagist

    From 4.2.0 · fixed in 4.2.9

  • civicrm/civicrm-corePackagist

    From 4.3.0 · fixed in 4.3.3

References 2

civicrm.org

issues.civicrm.org