Skip to main content
← All vulnerabilities
CVE-2013-4491GHSA-699M-MCJM-9CW8

Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/translation_helper.rb in the internationalization component i

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.2.16, 4.0.2
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/translation_helper.rb in the internationalization component in Ruby on Rails 3.x before 3.2.16 and 4.x before 4.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted string that triggers generation of a fallback string by the i18n gem.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • actionpackRubyGems

    From 3.0.0 · fixed in 3.2.16

  • actionpackRubyGems

    From 4.0.0 · fixed in 4.0.2

References 14

rhn.redhat.com

lists.opensuse.org

secunia.com

securityfocus.com

groups.google.com

weblog.rubyonrails.org

getchef.com

debian.org

puppet.com