CVE-2013-4330GHSA-X9FV-C87W-55WC
Apache Camel before 2.9.7, 2.10.0 before 2.10.7, 2.11.0 before 2.11.2, and 2.12.0 allows remote attackers to execute arbitrary simple langua
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.9.7, 2.10.7, 2.11.2, 2.12.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Apache Camel before 2.9.7, 2.10.0 before 2.10.7, 2.11.0 before 2.11.2, and 2.12.0 allows remote attackers to execute arbitrary simple language expressions by including "$simple{}" in a CamelFileName message header to a (1) FILE or (2) FTP producer.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- org.apache.camel:camel-coreMaven
fixed in 2.9.7
- org.apache.camel:camel-coreMaven
From 2.10.0 · fixed in 2.10.7
- org.apache.camel:camel-coreMaven
From 2.11.0 · fixed in 2.11.2
- org.apache.camel:camel-coreMaven
From 2.12.0 · fixed in 2.12.1