CVE-2013-4287GHSA-9J7M-RJQX-48VH
Algorithmic complexity vulnerability in Gem::Version::VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.1, 1.8.24 through
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.8.23.1, 1.8.26, 2.0.8, 2.1.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Algorithmic complexity vulnerability in Gem::Version::VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.1, 1.8.24 through 1.8.25, 2.0.x before 2.0.8, and 2.1.x before 2.1.0, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- rubygems-updateRubyGems
fixed in 1.8.23.1
- rubygems-updateRubyGems
From 1.8.24 · fixed in 1.8.26
- rubygems-updateRubyGems
From 2.0.0 · fixed in 2.0.8
- rubygems-updateRubyGems
From 2.1.0.rc.1 · fixed in 2.1.0