Skip to main content
← All vulnerabilities
CVE-2013-3567GHSA-F7P5-W2CR-7CP7

Puppet 2.7.x before 2.7.22 and 3.2.x before 3.2.2, and Puppet Enterprise before 2.8.2, deserializes untrusted YAML, which allows remote atta

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.22, 3.2.2
None on Exploit-DB, Metasploit or GitHub

Summary

Puppet 2.7.x before 2.7.22 and 3.2.x before 3.2.2, and Puppet Enterprise before 2.8.2, deserializes untrusted YAML, which allows remote attackers to instantiate arbitrary Ruby classes and execute arbitrary code via a crafted REST API call.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • puppetRubyGems

    From 2.7.0 · fixed in 2.7.22

  • puppetRubyGems

    From 3.2.0 · fixed in 3.2.2

References 8

secunia.com

lists.opensuse.org

debian.org

ubuntu.com

puppetlabs.com

rhn.redhat.com