Skip to main content
← All vulnerabilities
CVE-2013-2082GHSA-WP3G-PR4H-Q6VV

Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not enforce capability requirements for reading

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.10, 2.3.7, 2.4.4
None on Exploit-DB, Metasploit or GitHub

Summary

Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not enforce capability requirements for reading blog comments, which allows remote attackers to obtain sensitive information via a crafted request.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.2.10

  • moodle/moodlePackagist

    From 2.3.0 · fixed in 2.3.7

  • moodle/moodlePackagist

    From 2.4.0 · fixed in 2.4.4

References 6

git.moodle.org

lists.fedoraproject.org

openwall.com

moodle.org