Skip to main content
← All vulnerabilities
CVE-2013-2081GHSA-X3X8-FJW6-HCCX

Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not consider "don't send" attributes during hub

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.10, 2.3.7, 2.4.4
None on Exploit-DB, Metasploit or GitHub

Summary

Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not consider "don't send" attributes during hub registration, which allows remote hubs to obtain sensitive site information by reading form data.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 2.2.10

  • moodle/moodlePackagist

    From 2.3.0 · fixed in 2.3.7

  • moodle/moodlePackagist

    From 2.4.0 · fixed in 2.4.4

References 6

git.moodle.org

moodle.org

lists.fedoraproject.org

openwall.com